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1. Version History    

 
Version #:   1.0   
Supersedes:   n/a   
 
Handwritten amendments to the official procedures can be made by a single line 
through the text, along with the date, and initialed by the authorized individual making 
the correction.  Changes are to be noted below.  Formal changes to this SOP are made 
on the date of revision or sooner, where required. 
 

Section Changes made to official copy Date Initials 
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2. Introduction 

This procedure outlines the proper operation of the Thunder Scientific Series 1200 Mini 
Two-Pressure Humidity Generator. The humidity generator produces known humidity 
values inside a regulated chamber for instrument calibration and evaluation using the 
fundamental principle of the “two pressure” generator originally developed by NIST. The 
machine is able to generate manually entered humidity and temperature set-points as 
well as multipoint profiles completely unattended, while continuously recording and 
printing system data. Virtually all functions are controlled automatically through the use 
of an embedded computer. Operator interaction is through the integral touch panel or 
USB keyboard and mouse. 
 
3.  Definitions 

Assurance If selected, forces the system to wait until the measured parameters and 
the set point values are within specified tolerances before beginning the 
soak time 

Pc Chamber pressure 
PPMv Parts per million by volume 
PPMw Parts per million by weight 
ramp time The time allowed for the system to transition from one set point to the 

next set point 
RH Relative humidity 
RH @PcTc Relative humidity calculated at test chamber pressure and test chamber 

temperature 
RH @Pc Relative humidity calculated at test chamber pressure (ignoring possible 

differences between saturation temperature and chamber temperature) 
soak time The time that the system will remain at a particular set point before 

proceeding to the next set point 
Tc Chamber temperature 
 
4.  Personnel 

Persons authorized to perform this SOP: 
 

By signing this form I acknowledge that I have read and understand this SOP, as well 
as the applicable MSDS’s and that I will conduct myself in accordance with this SOP 
and the general laboratory rules. 
 
NOTE:  ALL SIGNATURES MUST BE PRESENT ON THE SOP LOCATED IN THE YELLOW 
BINDER IN ROOM 1B39.1.1 – the Heat Transfer Departmental Assistant’s Office. 
Digital copies of SOP’s are made available for reference and convenience only.  
Printed SOP’s are valid for 24 hours only, after that time their accuracy must be 
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verified with the OFFICIAL HARDCOPY VERSION. A reference copy of this SOP can be 
found beside the machine in room 1B39.1. 
 

Name (Print) NSID Dep’t Signature Date 

     

     
     

     
     

     

     

     

     
     

     
     

     
     

     

     
     

     
     

     

     
     

     
     

     
     

     

     
     

     
     



University of Saskatchewan 

Department of Mechanical Engineering 

Standard Operating Procedure # HT0006 

 

 Page 5 of 9  

5. Safety 

 The operating range of the humidity generator is 10% RH to 95% RH and 10°C to 
60°C. 

 Ensure the water reservoir has enough water to perform the entire test. 

 Do not overfill the water reservoir. 
 

6.  Procedure 

6.1 Power Up 

 Turn on the computer (back panel of the humidity chamber) and the air 
compressor (back of the air compressor on the bottom of the cart). 

 The software program will automatically launch on start-up. If it does not, or if 
the program has been closed, launch the Mini 1200 program from the desktop. 

 At the end of the power-up sequence a window showing the water level and 
supply pressure will appear. 

o If the distilled water reservoir is at least half full the “Presaturator” 
indicator will be green. This means the system is ready to be used. 

o If the water level is low, add more water to the reservoir. 
 Remove the reservoir cap on the top of the machine with an 

11/16 in wrench. 
 Fill the reservoir with distilled water. While filling, the water level 

gauge will update to reflect the present level. Note: the water 
level updates sporadically. Add a small amount of water then 
wait for the water level to update before adding more. 

 Once the reservoir is full, replace the reservoir cap. Be sure not to 
over tighten the cap. You should be able to tighten it with your 
fingers and then give it one small turn with the wrench. 

o The supply pressure should be approximately 160 psiG. 
 
The humidity generator can run in two modes: generate and automated. The generate 
mode is used to generate a desired relative humidity and/or temperature inside the 
chamber. In automated mode, the user can create a profile containing multiple set 
points and set the length of time the generator will remain at each set point. 
 
To begin, insert the sensors into the chamber. If the sensors are stand-alone units they 
can be placed inside the door to the chamber. If the sensors are connected to data 
acquisition cables or other wires, they will need to be fed into the chamber through the 
hole in the right side. Ensure that the hole is closed with a Styrofoam block to prevent 
leakage. Ensure that the chamber door is closed and latched properly. 
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6.2 Generate Mode 

 Using a stylus or the mouse, click on the %RH @PcTc - Set Point field of the Main 
Screen window. 

 Enter the desired set point in the dialog box that appears. Use either a stylus, a 
mouse with the on-screen keyboard, or the attached USB keyboard. The 
acceptable range is 10% RH to 95% RH. 

 Click OK. 

 Click on the Saturation Temp – Set Point field. 

 Enter the chosen set point value. The acceptable range is 10°C to 60°C. 

 Click OK. 

 Click on the Mass Flow Rate – Set Point field. 

 Enter the chosen set point value. This is typically set to 10 L/min for best 
performance. 

 Click OK. 

 Select Run → Generate from the Top Menu. 
o All fields on the Main Screen will begin to update with current data. 
o Stabilization time of the control points will vary based on distance from 

set points and distance of the set points from ambient conditions. Ample 
time should be allowed for the system and instrumentation being 
calibrated to stabilize and equilibrate to the set point. 

 To change any of the set point values, click on the appropriate Set Point field and 
enter a new value. Click OK. 

 When the test is complete, select Run → Shutdown from the Top Menu. 
o After shut down is complete, the program will prompt the user to save 

the data. Choose Yes and enter a valid file name or choose No to exit 
without saving. If you are going to save the data, create a folder with 
your name and save the data file in that folder. 

 

6.3 Automated Mode 

 To create a new profile, select Profile → New Profile from the Top Menu. 

 Enter the required values for: 
o %RH @PcTc 
o Saturation fluid temperature 
o mass flow rate – typically 10 L/min 
o ramp time (in hours) – typically set to 0 hrs. 
o soak time (in hours) – depends on the response time of the 

instrumentation being calibrated, typically 1 hr. 
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o a “Y” or a “N” for assured soak – set to “Y” to ensure the chamber 
reaches the set point values before beginning the soak time. If “N” is 
selected, it is possible that the system will move on to the next set point 
before the instrument being calibrated has reached equilibrium. 

 Use the < and > buttons on the panel to move between set points.  

 If Assured Soak is selected, the user will be prompted to enter Assurance 
Conditions. These tolerances must be met before the Soak phase will begin. If 
the window does not automatically open it can be found under Profile → 
Assurance Conditions. Typical values are: 

o 0.2 %RH, 
o 0.1°C, and 
o 0.5 L/min. 

 After entering all set points, select Profile → Save Profile. Enter a valid file name 
and click OK. Create a folder with your name and save the profile to this folder. 

 To open an existing profile, select Profile → Open Profile. Choose an existing 
profile and click OK. 

 To run the humidity generator using a profile, select Run → Auto Profile. 

 A dialog box showing the current profile will appear. If this is the correct profile 
select the starting set point, then click OK. 

o If this is not the correct profile, click Cancel and then open an existing 
profile or create a new profile with the correct information. 

 The actual values boxes will turn yellow until the values agree with the set point 
values, within the selected Assurance Conditions. 

 Manual Control (from the Run Menu) 
o Hold Point – used to hold the humidity generator at the current set point, 

ignoring the pre-set time limits. To resume the profile, select Hold Point 
again. 

o Next Point – allows the user to skip to the next set point 

 The program will display the current step out of the total number of steps in the 
profile in the bottom of the window. It will also list if the program is in the 
Assurance or Soak portion of the profile. 

 After the last soak phase has completed, the humidity generator will 
automatically go into shutdown mode. 

 To shut down the program prior to the last set point, select Run → Shutdown 
from the Top Menu. 

 
6.4 Data Storage and Retrieval 

 To save a copy of the current data file select File → Save Data As. Enter an 
appropriate file name, then click OK. Create a folder with your name and save 
the data to this folder. 

 The data interval determines when the data is stored. The default is one minute. 
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o To change the data storage interval, select File → Data Storage Interval. 
o Enter the new time interval and click OK. 

 
6.5 Additional Information 

 To view a log of the system status, logging start times, set point changes and 
runtime errors, select Window → Status Log. 

 To check the water level and supply pressure, select Window → Water Level and 
Supply Pressure. 

o If the water level is low, ensure that the machine is not generating a set 
point before refilling the water level. 

o The supply pressure should be a maximum of 150 psiG while the machine 
is in use (actively generating a set point) and approximately 160 psiG 
when the system is idle. 

 The humidity generator is typically controlled based on the %RH @PcTc. 
o It may also be controlled based on %RH @Pc, frost point, dew point, 

PPMv, PPMw or saturation pressure. 
o To change the control mode select a different parameter under the 

Mode menu. 
 
6.6 Shutdown 

 If the program is currently running a profile, wait until the profile is complete, or 
select shut down from the Run menu. 

 Once the machine has stopped actively generating a set point, it can be shut 
down. 

 Click on the small x in the upper right corner of the program window. You will be 
prompted to save data at this point. 

 Once the program has closed, select Start → Shutdown. 

 The computer will tell you when it is acceptable to turn off the power. 

 Turn off the power to the computer and the air compressor. 
 
7.  Equipment or Materials Required 

 Sensor or instrumentation for calibration 

 11/16 in wrench to remove the reservoir cap  

 Distilled water to fill the reservoir 
 
8. Trouble Shooting 

If you encounter problems that you are unsure how to deal with, consult the 
Departmental Assistant in the lab. The following is a list of some possible problems that 
might occur and how to solve them.  
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Problem: Look for  

Supply Pressure Low Ensure the air compressor is on 

Select a different RH set point 

Reservoir Water Empty Fill the reservoir with water 

Flow Rate Min Value Limit Select a higher flow rate 
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